Knowledgebase: Solar Vault
Cannot start SolarVault Pro / SolarVault Lite on Windows guest VM on VMware Fusion server with mirrored desktop folder
Posted by Support on 23 January 2014 01:51 PM

Product Version:
SolarVault Lite / SolarVault Pro: All

OS: Windows

    1. Problem Description:
For VMware Fusion virtual machine installation on Windows platforms, if the mirrored desktop option is enabled, SolarVault Pro / SolarVault Lite cannot start after its installation.

Upon further investigation, if the client agent is started in Debug Mode, the following error messages would be received in the command prompt:

java.lang.SecurityException: Access is denied.

       at com.ahsay.ani.util.WindowsUtil.mkdir(Thread.java:597)
       at com.ahsay.afc.util.q.a(Unknown Source)
       at com.ahsay.afc.util.q.b(Unknown Source)
       at com.ahsay.obc.core.h.(Unknown Source)
...

Note:
Mirrored folders allow the Mac and the virtual machine to see the same content in certain personal data folders, for example the desktop folder.
    1. Cause:
Mirrored folders option (http://kb.vmware.com/kb/1014127) is not supported for SolarVault Pro / SolarVault Lite.
    1. Resolution:
To resolve the issue, please disable the 'Shared Folders (Mirrored Folders)' option to allow SolarVault Pro / SolarVault Lite to start. 


Figure 1.0 - VMware Fusion console (Settings)